On 1/12/13 9:19 AM, Derick Rethans wrote:
I'm liking this, why start with an function alias already when
introducing a new feature?
I figured this would be a frequent question, and I was right. :-)
In earlier discussions (June 2012), when I first introduced array_column(), much of the discussion revolved around the name and not the functionality. I agreed with arguments for array_column() and arguments for array_pluck(), so I added an alias.
Here's why I think the alias should be considered:
1) Userland PHP developers instantly recognize array_column(). It's self-descriptive, and they know what it means.
2) Developers coming from other languages (Ruby, JavaScript, etc.) will instantly recognize array_pluck(). It's what they'll be looking for to do the same thing, but they won't be looking for array_column().
-Ben