Wyświetlanie plików 3D w Podglądzie na Macu
Możesz wyświetlać pliki 3D w aplikacji Podgląd oraz zmieniać sposób ich przedstawiania w obszarze widocznym, czyli miejscu wyświetlania, nawigacji i interakcji z nimi. Plik 3D może zawierać scenę lub obiekt. Podczas wyświetlania sceny masz wrażenie przebywania w niej i możesz rozglądać się wokoło. W trakcie oglądania obiektu można go obracać w dowolnym kierunku.
Uwaga: W przypadku plików SceneKit (.scn) i Collada (.dae) niektóre funkcje wyświetlania i edytowania obiektów 3D nie są dostępne.
Otwieranie pliku 3D
Przejdź do aplikacji Podgląd
na Macu.
Wybierz polecenie menu Plik > Otwórz.
Przejdź do folderu zawierającego plik, a następnie kliknij dwukrotnie w ten plik.
Uwaga: Pliki USD mogą być niezależne, ale często odwołują się do innych plików potrzebnych do wyświetlenia sceny lub zasobu. Nie należy wyjmować pliku USD z oryginalnego folderu, ponieważ w takiej sytuacji wyświetlenie sceny nie będzie możliwe. Folder może również zawierać więcej niż jeden plik USD.
Eksplorowanie sceny 3D
Możesz poruszać się po scenie, obracając ją (orbitując wokół punktu centralnego), przesuwając oraz przybliżając i oddalając.
Przejdź do aplikacji Podgląd
na Macu.
Otwórz plik 3D, a następnie wykonaj dowolne z następujących czynności:
Obracanie sceny: Przeciągaj w dowolnym miejscu obszaru widocznego, aby poruszać się po scenie.
Przesuwanie: Przeciągnij dwoma palcami po gładziku, lub przeciągnij przy użyciu środkowego przycisku myszy.
Zoom: Zsuń dwa palce na gładziku, przewiń myszą lub przeciągnij przy użyciu prawego przycisku myszy.
Powiększanie do zaznaczenia: Wybierz polecenie menu Widok > Dopasuj do zaznaczenia lub naciśnij Shift‑Command‑8. Jeśli nic nie jest zaznaczone, Podgląd dopasuje całą scenę do obszaru widocznego.
Aby trwale zmienić orientację lub rozmiar sceny (zamiast jedynie zmieniać widok), zobacz: Edytowanie pliku 3D w Podglądzie na Macu (sekcja „Korygowanie sceny”).
Przeglądanie obiektów w scenie
Sceny 3D składają się z prymitywów, które reprezentują obiekty — kształty, światła, kamery i materiały. Są one ułożone hierarchicznie. Prymitywy w scenie 3D możesz przeglądać w panelu Hierarchia obiektów.
Przejdź do aplikacji Podgląd
na Macu.
Otwórz plik 3D, a następnie wybierz polecenie menu Widok > Hierarchia obiektów.
Wykonaj dowolne z następujących czynności:
Zaznaczanie grupy lub prymitywu: Kliknij w nazwę lub naciśnij klawisz Strzałka w górę lub Strzałka w dół.
Rozwijanie lub zwijanie grupy: Kliknij w
lub
. Możesz także nacisnąć klawisz Strzałka w prawo lub Strzałka w lewo.
Ukrywanie lub pokazywanie grupy lub prymitywu: Kliknij w
obok nazwy.
Oznaczanie prymitywu jako odwołania głównego pliku: Kliknij z klawiszem Control w prymityw, a następnie wybierz Odwołanie główne pliku. Obok nazwy pojawi się gwiazdka. Odwołanie główne pliku to prymityw używany domyślnie przez inne pliki odwołujące się do bieżącego pliku, a także miejsce, do którego Podgląd dodaje nowe prymitywy, gdy nic nie jest zaznaczone.
Widok z kamery
Możesz oglądać scenę z perspektywy dowolnej kamery zdefiniowanej w pliku 3D lub z widoku domyślnego Perspektywa, który jest zawsze dostępny jako pierwszy w panelu kamer.
Przejdź do aplikacji Podgląd
na Macu.
Otwórz plik 3D, a następnie wybierz polecenie menu Widok > Aparaty.
W panelu kamer kliknij w miniaturkę kamery, aby wyświetlić scenę z jej perspektywy.
Miniaturki to podglądy na żywo, które pokazują, w jakim kierunku skierowane są poszczególne kamery. Kamera, przez którą obecnie wyświetlasz scenę, jest podświetlona. Aby wrócić do domyślnego widoku, kliknij w Perspektywa.
Aby zablokować lub odblokować zaznaczoną kamerę, kliknij w
.
Zablokowanie uniemożliwia obracanie widoku (orbitowanie wokół niego), przesuwanie go oraz przybliżanie i oddalanie podczas korzystania z danej kamery. Nadal jednak możesz przesuwać prymitywy za pomocą uchwytów transformacji oraz edytować właściwości kamery w panelu Właściwości obiektu. Stan blokady nie jest zachowywany w pliku. Nie można także odblokować kamery z animacją. Blokowanie kamery nie jest dostępne dla widoku Perspektywa, który zawsze umożliwia swobodną nawigację.
Wybieranie stylu renderowania
Przejdź do aplikacji Podgląd
na Macu.
Otwórz plik 3D, a następnie wybierz polecenie menu Widok > Rendering 3D.
Wykonaj dowolne z następujących czynności:
Wyświetlanie zawartości w postaci przedstawianej na platformach Apple: Wybierz RealityKit (jest on wybrany domyślnie).
Używanie uniwersalnego silnika renderującego zapewniającego szeroką zgodność z formatem USD: Wybierz OpenUSD Storm.
Uzyskiwanie wysokiej jakości renderowania opartego na fizyce: Wybierz Raytracer.
Renderowanie sceny z realistycznym oświetleniem i materiałami, aby uzyskać efekt zdjęcia: Wybierz Rendering fotorealistyczny. Możesz również kliknąć w
, a następnie kliknąć w
. Gdy włączony jest rendering fotorealistyczny, narzędzia Renderer oraz Środowisko są niedostępne. Jeśli scena nie zawiera żadnych źródeł światła, wyświetlone zostanie okno dialogowe. Aby kontynuować, kliknij we Włącz mimo to. W przeciwnym razie kliknij w Anuluj. Aby dodać światło, zobacz: Dodawanie prymitywu.
Wybieranie oświetlenia: Pod etykietą Środowisko wybierz: Studio, Zachmurzenie, Słonecznie, Zmierzch, Noc, Miasto nocą lub Wnętrze biura. Możesz również kliknąć w
, kliknąć w
, a następnie wybrać żądaną opcję. Gdy włączony jest rendering fotorealistyczny, narzędzia Środowisko są niedostępne.
Aby zmienić domyślny silnik renderujący, wybierz polecenie menu Podgląd > Ustawienia, kliknij w 3D, a następnie wybierz nowy renderer w menu podręcznym Domyślny renderer.
Korygowanie wyglądu obszaru widocznego
Możesz skorygować odległość cienia, ekspozycję i gammę, aby zmienić wygląd sceny w obszarze widocznym.
Przejdź do aplikacji Podgląd
na Macu.
Otwórz plik 3D, a następnie kliknij w
.
Kliknij w
na pasku narzędzi.
Wykonaj dowolne z następujących czynności:
Kontrolowanie zasięgu rzucanych cieni w scenie: Gdy wybrany jest silnik renderujący Raytracer, a opcja Renderowanie fotorealistyczne jest wyłączona, przeciągnij suwak Odległość cienia lub wprowadź wartość.
Zwiększenie lub zmniejszenie jasności sceny: Przeciągnij suwak Ekspozycja lub wprowadź wartość.
Korygowanie zakresu tonalnego sceny: Przeciągnij suwak Gamma lub wprowadź wartość.
Przywracanie wartości domyślnych odległości cienia, ekspozycji i gammy: Kliknij w Wyzeruj wszystko.
Odtwarzanie animacji
Jeśli plik 3D zawiera animację, możesz ją odtwarzać za pomocą narzędzi odtwarzania. Domyślnie animacje odtwarzane są w pętli.
Przejdź do aplikacji Podgląd
na Macu.
Otwórz plik 3D, a następnie przesuń wskaźnik na dół widoku, aby wyświetlić narzędzia odtwarzania (lub naciśnij spację).
Wykonaj dowolne z następujących czynności:
Włączanie lub wstrzymywanie odtwarzania: Kliknij w
lub
w narzędziach odtwarzania (lub naciśnij spację).
Odtwarzanie animacji tylko raz zamiast w pętli: Kliknij z klawiszem Option w
.
Przechodzenie do tyłu lub do przodu o pięć jednostek: Kliknij w
lub
.
Zmienianie jednostek miary: Kliknij w bieżącą miarę, aby przełączyć się między klatkami (wartość domyślna) a minutami:sekundami.
Przechodzenie do określonej klatki: Przeciągnij uchwyt przewijania na pasku odtwarzania.
Uwaga: Podczas odtwarzania nie można zaznaczać ani przesuwać obiektów, dodawać lub edytować adnotacji ani używać narzędzi na pasku narzędzi. Nadal można jednak zmieniać właściwości, dodawać lub usuwać prymitywy oraz cofać zmiany.
Wyświetlanie informacji o pliku
Na pasku bocznym Inspektora można wyświetlać informacje o pliku 3D, takie jak nazwa pliku, wielkość, data utworzenia, data modyfikacji, obiekty, materiały oraz światła.
Przejdź do aplikacji Podgląd
na Macu.
Otwórz plik 3D, a następnie kliknij w
na pasku narzędzi.
Możesz również przeglądać pliki USD, obrazki i pliki PDF zachowane na Macu, używając Apple Vision Pro. Zobacz: Wyświetlanie zawartości z Maca na Apple Vision Pro.