Hi Anatol,
As of renaming LONG to INT there is one small inconsistence in the RFC:
- ZEND_STRTOL/ZEND_STRTOUL should be ZEND_STRTOI/ZEND_STRTOUI
- SIZEOF_ZEND_INT should be ZEND_INT_SIZEOF to be consistent with
ZEND_INT_MAX/ZEND_INT_MIN/ZEND_UINT_MAX
And in my opinion if we go to rename LONG to INT with BC we should also
rename DOUBLE to FLOAT :)
Marc
On 27.01.2014 21:15, Anatol Belski wrote:
> https://wiki.php.net/rfc/size_t_and_int64
>
> There was two big questions regarding the compatibility. Those open
> questions appeared in the discussions are reflected in the reworked RFC.
>
> First question, the possibility to keep the old zend_parse_parameters()
> specs 'l', 'L', 's', 'p' along with new 'i',
> 'I', 'S', 'P'. Keeping the
> old zpp specs will for sure minimize the porting effort for the PECL
> extensions, but might lead to confusion (like people might think ‘l’ still
> expects ‘long’ and not ‘php_int_t’). Please use the yes/no Vote 3 to
> decide whether the ‘l’, ‘L’, ‘s’, ‘p’ have to stay supported.
>
> Second question, the macro renames for LONG<>INT, STRLEN<>STRSIZE, etc.
> The reason for such renamings was to ensure source level incompatibility
> on compile time. However this might have a negative effect on the porting
> effort (despite the porting tools). Please use the yes/no Vote 2 to decide
> whether the old macro names have to be kept.
>
> The Vote 1 is the main vote for this patch. The both Votes 2 and 3 are
> merely to decide about the semantical replacements choosen for the patch.
> Should the Votes 2 and 3 result in reverting of that semantical changes,
> the essential patch part about the 64 bit support will not be hurt.
> Reverting to old macro names or zpp specs is only the naming issue.
>
> Removal of the dead SAPIs is isolated in a separate RFC and can be
> considered to another time.
>
> Thanks for the constructive discussions on this RFC, support and testing.
> The vote begins Monday, 27 January 2014, 21:30 CET and ends Monday, 03
> February 2014, 21:30 CET.
>
>